您的位置:首页 > 其它

Let the Balloon Rise

2015-08-04 11:19 302 查看

Let the Balloon Rise
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 6

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the
result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output

red
pink

#include<iostream>
#include<string>
#include<stdio.h>
#include<map>
using namespace std;
int main()
{
map<string,int> m;
//map<string,int>::iterator it;
int Max;
string s;
int n;
int i,j;
while(scanf("%d",&n),n)
{
Max=-1;
for(i=0;i<n;i++)
{
cin>>s;
m[s]++;
}
for(map<string,int>::iterator it=m.begin();it!=m.end();it++)
if((*it).second>Max)
{ s=(*it).first; Max=(*it).second;}
cout<<s<<endl;
m.clear();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: