您的位置:首页 > 其它

Prime Ring Problem HDU 杭电1016

2015-08-04 10:45 453 查看
Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.





Input

n (0 < n < 20).



Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.



Sample Input

6
8




Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2




#include<stdio.h>
#include<string.h>
int vis[30],a[30];
int IsPrime(int x)//素数判定 
{
	for(int i=2;i*i<=x;++i)
	{
		if(x%i==0) return 0;
	}
	return 1;
}

void DFS(int n,int c)
{
	if(c==n)//当找到完n个相邻的素数之后
	{
		if(IsPrime(a
+1))//判断首位是否满足相加为素数
		{
			printf("1");
			for(int i=2;i<=n;++i)
				printf(" %d",a[i]);
			printf("\n");
		}		
		return ;
	}
	for(int i=2;i<=n;++i)
	{
		if(!vis[i]&&IsPrime(a[c]+i))//一个一个找,找到i后把i赋给a[c],c为现在找到的个数
		{
			a[c+1]=i;
			vis[i]=1;
			DFS(n,c+1);
			vis[i]=0;
		}
	}
}
int main()
{
	int n,num=0;
	while(~scanf("%d",&n))
	{
		//printf("%d ",IsPrime(n));
		memset(vis,0,sizeof(vis));
		printf("Case %d:\n",++num);
		vis[1]=1;
		a[1]=1;
		DFS(n,1);
		printf("\n");
	} 
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: