您的位置:首页 > 其它

hdu 1754 I Hate It

2015-08-04 09:17 176 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1754

I Hate It

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 49750 Accepted Submission(s): 19544


[align=left]Problem Description[/align]
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

[align=left]Input[/align]
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

[align=left]Output[/align]
对于每一次询问操作,在一行里面输出最高成绩。

[align=left]Sample Input[/align]

5 6
1 2 3 4 5

Q 1 5

U 3 6

Q 3 4

Q 4 5

U 2 9

Q 1 5

[align=left]Sample Output[/align]

5
6

5

9

Hint

Huge input,the C function scanf() will work better than cin

更新区间内某一点然后找最大值

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define N 200010
#define Lson root<<1, L, tree[root].Mid()
#define Rson root<<1|1, tree[root].Mid() + 1, R

using namespace std;

struct Tree
{
int L, R, Max;
int Mid()
{
return (L + R) / 2;
}
}tree[N * 4];

int al
;

void Build(int root, int L, int R)
{
tree[root].L = L, tree[root].R = R;
if(L == R)
{
tree[root].Max = al[L];
return ;
}

Build(Lson);
Build(Rson);

tree[root].Max = max(tree[root<<1].Max, tree[root<<1|1].Max);
}

void Update(int root, int k, int e)
{
if(tree[root].L == tree[root].R)
{
tree[root].Max = e;
return ;
}
if(k <= tree[root].Mid())
Update(root<<1, k, e);
else
Update(root<<1|1, k, e);
tree[root].Max = max(tree[root<<1].Max, tree[root<<1|1].Max);//更新k点后,还要更新节点的最大值,上一区间节点的最大值取下面左右两个区间节点的最大值
}

int Query(int root, int L, int R)
{
if(tree[root].L == L && tree[root].R == R)
return tree[root].Max;
if(R <= tree[root].Mid())
return Query(root<<1, L, R);
else if(L > tree[root].Mid())
return Query(root<<1|1, L, R);
else
return max(Query(Lson), Query(Rson));
}

int main()
{
int n, m, a, b, i;
char s[10];
while(~scanf("%d%d", &n, &m))
{
for(i = 1 ; i <= n ; i++)
scanf("%d", &al[i]);
Build(1, 1, n);
while(m--)
{
scanf("%s%d%d", s, &a, &b);
if(s[0] == 'U')
Update(1, a, b);
else
printf("%d\n", Query(1, a, b));
}
}
return 0;
}
/*
10 2
1 2 3 4 5 10 6 7 8 9
U 6 8
Q 1 6
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: