您的位置:首页 > 其它

hdoj1312Red and Black(递归)

2015-08-04 09:00 309 查看

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13136 Accepted Submission(s): 8136



Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.



Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)



Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).



Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0




Sample Output
45
59
6
13


题意:某人在@处为起点(也包括@点)#为墙,点(.)为通路,问最多能走多远统计能走几个点(加上@这个点)

#include<stdio.h>
char a[50][50];
int n,m,count;
void fun(int x,int y)
{
	
	if(a[x][y]=='#')//看看是不是墙 
	return ;
	if(x>m||y>n||x<1||y<1)//在范围内 
	return ;
	count++;
	a[x][y]='#';//已经查到得这个点就要变成墙,否则的话 就变成无限的查找了 
	fun(x-1,y);//查上下左右四个点 
	fun(x+1,y);
	fun(x,y+1);
	fun(x,y-1);
	
}
int main()
{
	int i,j,b,c;
	while(~scanf("%d %d",&n,&m))//n行m列 
	{
		count=0;
		if(n==0||m==0)
		return 0;
		for(i=1;i<=m;i++)
		{
			getchar();
			for(j=1;j<=n;j++)
			{
				scanf("%c",&a[i][j]);//找出@点在几行几列 
				if(a[i][j]=='@')
				b=i,c=j;
			}
		}
		fun(b,c);//查一下在这个点周围还有几个点 
		printf("%d\n",count);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: