您的位置:首页 > 其它

hdu 1969

2015-08-03 21:21 246 查看

Pie

Time Limit : 5000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 190 Accepted Submission(s) : 72
[align=left]Problem Description[/align]
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them
gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

[align=left]Input[/align]
One line with a positive integer: the number of test cases. Then for each test case: ---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends. ---One
line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

[align=left]Output[/align]
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute
error of at most 10^(-3).

[align=left]Sample Input[/align]

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2


[align=left]Sample Output[/align]

25.13273.141650.2655

源代码

<span style="font-size:18px;">#include<stdio.h>
#include<math.h>
#define PI acos(-1.0)
double arr[10010]; //注意:精度double
int a,n,f;
double sum;
int fun(double x)
{
int cent=0;
for(int i=1;i<=n;++i)
cent+=(int)(arr[i]/x);//(int)arr[i]/x是把arr[i]强制转换成整型
if(cent>=f) return 1;//而题意是要把计算结果强制转换成整型
return 0;
}
int main()
{
scanf("%d",&a);
while(a--)
{
scanf("%d%d",&n,&f);
f+=1;
sum=0;
for(int i=1;i<=n;++i)
{
scanf("%lf",&arr[i]);
arr[i]=arr[i]*arr[i]*PI;
sum+=arr[i];
}
double left=0,right=sum;
double mid;
while((right-left)>1e-7)
{
mid=(left+right)/2;
if(fun(mid))
left=mid;
else
right=mid;
}
printf("%.4lf\n",mid);
}
return 0;
}
//二分思想 </span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: