您的位置:首页 > 其它

UVALive 4764 简单dp水题(也可以暴力求解)

2015-08-03 20:12 399 查看
B - Bing it
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Submit Status Practice UVALive 4764

Description




I guess most of you played cards on the trip to Harbin, but I'm sure you have never played the following card game. This card game has N rounds and 100000 types of cards numbered from 1 to 100000. A new card will be opened when each round begins. You can ``bing" this new card. And if the card you last ``bing" is the same with this new one, you will get 1 point. You can "bing" only one card, but you can change it into a new one. For example, the order of the 4 cards is 1 3 4 3. You can ``bing" 1 in the first round and change it into 3 in the second round. You get no point in the third round, but get 1 point in the last round. Additionally, there is a special card 999. If you ``bing" it and it is opened again, you will get 3 point.

Given the order of N cards, tell me the maximum points you can get.

Input

The input file will contain multiple test cases. Each test case will consist of two lines. The first line of each test case contains one integer N(2

N

100000). The second line of each test case contains a sequence of n integers, indicating the order of cards. A single line with the number ``0" marks the end of input; do not process this case.

Output

For each input test case, print the maximum points you can get.

Sample Input

2
1 1
5
1 999 3 3 999
0


Sample Output

1
3


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

int dp[100010];
bool vis[100010];
int a[100010];

int main(){
int n;

while(scanf("%d",&n)!=EOF){
if(n==0)
break;

memset(dp,0,sizeof(dp));
memset(a,0,sizeof(a));
memset(vis,false,sizeof(vis));

for(int i=0;i<n;i++){
scanf("%d",&a[i]);
}

int sum=-1;

int point=a[0];
vis[point]=true;

for(int i=1;i<n;i++){
int next=a[i];
if(!vis[next]){

dp[next]=dp[point];
vis[next]=true;
}
else{
if(next==999){
dp[next]=max(dp[point],dp[next]+3);
}
else{
dp[next]=max(dp[point],dp[next]+1);
}
}

point=next;

if(dp[next]>sum)
sum=dp[next];

}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: