您的位置:首页 > 其它

HDOJ Square Coins 1398【母函数】

2015-08-03 20:08 218 查看


Square Coins

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9761 Accepted Submission(s): 6692



Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are
available in Silverland.

There are four combinations of coins to pay ten credits:

ten 1-credit coins,

one 4-credit coin and six 1-credit coins,

two 4-credit coins and two 1-credit coins, and

one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.



Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.



Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.



Sample Input

2
10
30
0




Sample Output

1
4
27




Source

Asia 1999, Kyoto (Japan)



Recommend

Ignatius.L | We have carefully selected several similar problems for you: 1171 1085 2152 2082 1709



注意:k+=i*i

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>

using namespace std;

int n,m;
int c1[300];
int c2[300];
int f[310];
int generation(int x)
{
	for(int i=0;i<=x;i++){
		c1[i]=1;
		c2[i]=0;
	}
	for(int i=2;i<=17;i++){
		for(int j=0;j<=x;j++){
			for(int k=0;k+j<=x;k+=i*i){
				c2[j+k]+=c1[j];
			}
		}
		for(int j=0;j<=x;j++){
			c1[j]=c2[j];
			c2[j]=0;
		}
	}
	return c1[x];
}

void init()
{
	for(int i=1;i<301;i++){
		f[i]=generation(i);
	}
}

int main()
{
	int n;
	init();
	while(scanf("%d",&n),n){
		printf("%d\n",f
);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: