您的位置:首页 > 其它

hdoj 1969 pie【二分法】

2015-08-03 19:44 459 查看

Pie

Time Limit : 5000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 188 Accepted Submission(s) : 70
[align=left]Problem Description[/align]
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This
should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

[align=left]Input[/align]
One line with a positive integer: the number of test cases. Then for each test case: ---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends. ---One line with N integers ri with
1 <= ri <= 10 000: the radii of the pies.

[align=left]Output[/align]
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

[align=left]Sample Input[/align]

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2


[align=left]Sample Output[/align]

25.1327
3.1416
50.2655


分析:

二分法 求平均值的问题。有n个饼和m个同学,给出n个饼的半径,求每个同学平均能分几个,但是每块饼必须均分。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
double ff[100050];
int n,m;
double pi = acos (-1.0);

bool kk(double gg)
{
int cout=0;
int i;
for(i=0;i<n;i++)
{
cout+=int(ff[i]/gg);
}
if(cout>=m+1)
return true;
else
return false;
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
double r;
double sum=0.0;
for(int i=0;i<n;i++)
{
scanf("%lf",&r);
ff[i]=r * r * pi;
sum +=ff[i];
}
double max = sum / (m+1);
double l=0.0,g=0.0,mid=0.0;
g=max;
while (g-l > 1e-6)
{
mid=(l+g)/2;
if(kk(mid))
{
l = mid;
}
else
g=mid;
}
printf("%.4lf\n",mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: