您的位置:首页 > 其它

HPU-ACM暑期培训第2周14级个人赛:Problem E HDU 4883

2015-08-03 19:11 507 查看

Problem E

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 150   Accepted Submission(s) : 6
[align=left]Problem Description[/align]
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the
ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when
arriving the restaurant?
 

[align=left]Input[/align]
The first line contains a positive integer T(T<=100), standing for T test cases in all. Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer
Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time. Pay attention
that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.

 

[align=left]Output[/align]
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

[align=left]Sample Input[/align]

2
2
6 08:00 09:00
5 08:59 09:59
2
6 08:00 09:00
5 09:00 10:00

 

[align=left]Sample Output[/align]

11
6

 
AC-code:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[100000];
int main()
{
int n,m,i,x,h1,m1,h2,m2,j;
scanf("%d",&n);
while(n--)
{
memset(a,0,sizeof(a));
scanf("%d",&m);
while(m--)
{
scanf("%d %d:%d %d:%d",&x,&h1,&m1,&h2,&m2);
h1=h1*60+m1;
h2=h2*60+m2;
for(j=h1;j<h2;j++)
a[j]+=x;
}
printf("%d\n",*max_element(a,a+1500));
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: