您的位置:首页 > 其它

hdoj 1241 Oil Deposits【DFS】

2015-08-03 16:29 387 查看


Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18094 Accepted Submission(s): 10431



Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following
this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2


题目难度不大,关键是往 8个方向搜索!!!

代码如下:

#include<stdio.h>
char map[101][101];
int dir[8][2]={{1,0},{1,1},{1,-1},{0,1},{0,-1},{-1,1},{-1,0},{-1,-1}};
int m,n;
void dfs(int x,int y )
{
int i, dx, dy;
for( i=0; i<8; i++)
{
dx = x + dir[i][0];
dy = y + dir[i][1];
if( dx<0||dy<0|| dx>=m||dy>=n||map[dx][dy]=='*')
continue;
map[dx][dy] = '*';
dfs(dx,dy);
}
}
int main()
{
int i,j,k,t;
while(scanf("%d%d",&m,&n)!=EOF, m|n )
{
t = 0;
for(i = 0;i < m; i++)
scanf("%s",map[i]);
for(i = 0; i < m; i++)
for( j = 0; j < n; j++)
{
if(map[i][j]=='@')
{
dfs(i,j);
t++;
}
}
printf("%d\n",t);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: