您的位置:首页 > 其它

Poj 1979 Hdu 1312 Red and Black【dfs】

2015-08-03 14:50 447 查看

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13060    Accepted Submission(s): 8097

[align=left]Problem Description[/align]
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

 

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

[align=left]Sample Input[/align]

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 

[align=left]Sample Output[/align]

45
59
6
13

这个题意是,小数点代表可以走的路,# 代表不能走的路,@代表这个人当前位置,给出现在的场地布置,求出这个人最大的活动区间(可以包含当前位置)....

今天刚学过递归,这个算是很简单的 dfs 问题,只要用简单的递归就可以处理完成了.....具体见代码注释......

#include<stdio.h>
int t,n,m,i,j,sum;
char x[25][25],y;
void rab(int a,int b)//主要运行的函数
{
if(x[a][b]=='#')//遇到墙,本次递归结束
{
return;
}
if(a<0||a>m-1||b<0||b>n-1)//超出边界,递归结束
{
return;
}
++sum;//统计
x[a][b]='#';//当前已经统计过的,标记成 墙
rab(a+1,b);//用递归对上下左右四个方向进行搜索,判断,运算.....
rab(a-1,b);//
rab(a,b+1);//
rab(a,b-1);//
}
int main()
{
int a,b;
while(scanf("%d%d",&n,&m),m||n)
{
for(i=0;i<m;++i)
{
getchar();
for(j=0;j<n;++j)
{
scanf("%c",&y);
x[i][j]=y;
if(y=='@')//就一个位置,单独标记上....
{
a=i;b=j;
}
}
}
sum=0;
rab(a,b);//调用函数计算结果
printf("%d\n",sum);//输出....
}
return 0;
}


/*
2016年3月2日21:35 Poj
*/
#include<stdio.h>
#include<string.h>
int n,m,ans,dx[4]={-1,1,0,0},dy[4]={0,0,1,-1};
char map[25][25];
/*void dfs(int a,int b)
{
++ans;
map[a][b]='#';
for(int i=0;i<4;++i)
{
int tx=a+dx[i],ty=b+dy[i];
if(tx<0||tx>=n||ty<0||ty>=m||map[tx][ty]=='#')
{
continue;
}
dfs(tx,ty);
}
}*/
void dfs(int a,int b)
{
if(a<0||a>=n||b<0||b>=m||map[a][b]=='#')
{
return;
}
++ans;
map[a][b]='#';
for(int i=0;i<4;++i)
{
dfs(a+dx[i],b+dy[i]);
}
}
int main()
{
//freopen("shuju.txt","r",stdin);
while(scanf("%d%d",&m,&n),n|m)
{
memset(map,0,sizeof(map));
int x,y;
for(int i=0;i<n;++i)
{
scanf("%s",&map[i]);
}
for(int i=0;i<n;++i)
{
for(int j=0;j<m;++j)
{
if(map[i][j]=='@')
{
x=i;y=j;
}
}
}
ans=0;
dfs(x,y);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: