您的位置:首页 > 其它

poj 1860 Currency Exchange (最短路,Bellman-Ford算法)

2015-08-03 14:32 441 查看
Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing
in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected
in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain
6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104.

Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output
YES

Bellman-ford 算法的略微改版,感谢万能的标哥

#include <iostream>
#include <cstdio>
#include <cstring>
#define EXP 1e-9
#define MAX 110
using namespace std;

struct node
{
int a,b;
double r,c;
} E[MAX*2];
double dis[MAX];
int n,m,s;
double v;
int top;

bool Bellman_Ford()
{
memset(dis,0,sizeof(dis));
dis[s] = v;
bool flag;
while(dis[s] <= v + EXP)
{
flag = false;
for(int j=0; j<top; j++)
{
double ant = (dis[E[j].a] - E[j].c) * E[j].r;
if(dis[E[j].b] < ant)
{
dis[E[j].b] = ant;
flag = true;
}
}
if(!flag)
{
if(dis[s] > v)
return true;
else
return false;
}
}
return true;
}

int main()
{
//freopen("in.txt","r",stdin);
int a,b;
double Rab,Rba,Cab,Cba;
while(cin>>n>>m>>s>>v)
{
top = 0;
for(int i=0; i<m; i++)
{
cin>>a>>b>>Rab>>Cab>>Rba>>Cba;
E[top].a = a;
E[top].b = b;
E[top].r = Rab;
E[top].c = Cab;
top++;
E[top].a = b;
E[top].b = a;
E[top].r = Rba;
E[top].c = Cba;
top++;
}
if(Bellman_Ford())
printf("YES\n");
else
printf("NO\n");
}
return 0;
}


大神代码的模板

#include <iostream>
#include <cstdio>
#include <cstring>
#define MAX 110

using namespace std;

struct node
{
int a,b;
double r,c;
} E[MAX*2];
double dis[MAX];
int n,m,s;
double v;
int top;

bool Bellman_Ford()
{
memset(dis,0,sizeof(dis));
dis[s] = v;
bool flag;
for(int i=1; i<n; i++)
{
flag = false;
for(int j=0; j<top; j++)
{
if(dis[E[j].b] < (dis[E[j].a] - E[j].c)*E[j].r)
{
dis[E[j].b] = (dis[E[j].a] - E[j].c)*E[j].r;
flag = true;
}
}
if(!flag)
break;
}

for(int j=0; j<top; j++)
{
if(dis[E[j].b] <(dis[E[j].a] - E[j].c)*E[j].r)
return true;
}
return false;
}
int main()
{
//freopen("in.txt","r",stdin);
int a,b;
double Rab,Rba,Cab,Cba;
while(cin>>n>>m>>s>>v)
{
top = 0;
for(int i=0; i<m; i++)
{
cin>>a>>b>>Rab>>Cab>>Rba>>Cba;
E[top].a = a;
E[top].b = b;
E[top].r = Rab;
E[top].c = Cab;
top++;
E[top].a = b;
E[top].b = a;
E[top].r = Rba;
E[top].c = Cba;
top++;
}
if(Bellman_Ford())
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: