您的位置:首页 > 其它

POJ 1442 Black Box (优先队列)

2015-08-03 11:27 323 查看
Black Box

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 8706Accepted: 3575
Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:

ADD (x): put element x into Black Box;

GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1

N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8


It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.

Let us describe the sequence of transactions by two integer arrays:

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.

Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output
3
3
1
2

n个数,m次询问,每次一个数k, 输出第i次( 1<= i <=m )询问 输入第k个数时,第i小的数

本来优先队列直接模拟一下,结果tle了,再利用一个递减的队列s,第i次询问时,这个队列里装i个数,把前k个数中的最小的数都放在s中,当s中的数量==k 时,s.top()即是所求值

#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <cmath>
#include <map>
#define inf 0x3f3f3f3f
#define N 30001
using namespace std;
int a
;
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        priority_queue<int ,vector<int > ,greater<int> >q;
        priority_queue<int ,vector<int > ,less<int> >s;
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        int j=1;
        for(int i=1; i<=m; i++)
        {
            int x;
            scanf("%d",&x);
            for(; j<=x; j++)
                q.push(a[j]);
            while(s.size() < i)
            {
                s.push(q.top());
                q.pop();
            }
            while(!s.empty() && !q.empty() && q.top() < s.top())
            {
                int k1=q.top();
                q.pop();
                int k2=s.top();
                s.pop();
                q.push(k2);
                s.push(k1);
            }
            printf("%d\n",s.top());
        }
    }
    return 0;
}




                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: