您的位置:首页 > 其它

poj1936 假期计划第一水

2015-08-03 10:04 288 查看
All in All

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 29651Accepted: 12312
Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a
subsequence of t, i.e. if you can remove characters from t such that the
concatenation of the remaining characters is s.

Input

The
input contains several testcases. Each is specified by two strings s, t
of alphanumeric ASCII characters separated by whitespace.The length of s
and t will no more than 100000.
Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No


#include<string.h>
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
char s[100005],t[100005];
int main(){
while(scanf("%s %s",s,t)!=EOF){
getchar();
int len1=strlen(s);
int len2=strlen(t);
int ans=0;
for(int i=0;i<len2;i++){
if(s[ans]==t[i]){
ans++;
}
}
if(ans==len1)
printf("Yes\n");
else

printf("No\n");
memset(s,0,sizeof(s));
memset(t,0,sizeof(t));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: