您的位置:首页 > 其它

[周赛] HDU - 4970 Killing Monsters

2015-08-03 08:12 225 查看
[align=left]Problem Description[/align]
Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R.
Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in
block 2 and the last in block 3.

A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.

Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.

[align=left]Input[/align]
The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0
< Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi
<= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.

The input is terminated by N = 0.

[align=left]Output[/align]
Output one line containing the number of surviving monsters.

[align=left]Sample Input[/align]

5
2
1 3 1
5 5 2
5
1 3
3 1
5 2
7 3
9 1
0


[align=left]Sample Output[/align]
3


这道题题意并不难理解,但是按照常规想法就能实现,但是常规写法来写的画必定超时。想尽各种办法之后也没成功。最后借鉴了其他网友的一种优化方法。非常巧妙的对位置攻击力数组进行赋值。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define INF 0x3f3f3f3f

using namespace std;

long long int att[100010];
long long int hp;
int main()
{
int n,m,k,s;
int l,r,d;
int i;
while (scanf("%d",&n),n)
{
int t=0;
memset(att,0,sizeof(att));
scanf("%d",&m);
for (i=0;i<m;i++)
{
scanf("%d%d%d",&l,&r,&d);
att[l] += d;
att[r+1] -= d;
}
for (i=2;i<=n;i++)                                          //巧妙赋值
{
att[i]+=att[i-1];
}
for (i=n-1;i>=1;i--)
{
att[i] += att[i+1];
}
scanf("%d",&k);
int ans=k;
while(k--)
{
scanf("%lld%d",&hp,&s);
if(att[s]>=hp) ans--;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: