您的位置:首页 > 其它

BC - Untitled

2015-08-03 08:02 267 查看
[align=left]Problem Description[/align]
There is an integer a
and n
integers b1,…,bn.
After selecting some numbers from b1,…,bn
in any order, say c1,…,cr,
we want to make sure that a mod c1 mod c2 mod… mod cr=0
(i.e., a
will become the remainder divided by ci
each time, and at the end, we want a
to become 0).
Please determine the minimum value of r.
If the goal cannot be achieved, print −1
instead.

[align=left]Input[/align]
The first line contains one integer
T≤5,
which represents the number of testcases.

For each testcase, there are two lines:

1. The first line contains two integers n
and a
(1≤n≤20,1≤a≤106).

2. The second line contains n
integers b1,…,bn
(∀1≤i≤n,1≤bi≤106).

[align=left]Output[/align]
Print T
answers in T
lines.

[align=left]Sample Input[/align]

2
2 9
2 7
2 9
6 7


[align=left]Sample Output[/align]

2
-1


第一次打BC的第一道题,比赛结束前没A出来。这道题方法其实和poj1753一样,枚举步数然后在DFS找当前步数下所有元素能否构成符合题意的情况。此题关键在于要对b数组由大到小排序。排序之后只需要依次遍历如1,2,3;1,2,4;1,3,4;因为该题是不断对a取余,如果先对小的数取余那么余数一定比小的还要小,那么这时再对较大的数取余没有任何意义。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#define INF 0x3f3f3f3f

int cmp(int x,int y)
{
return x>y;
}
using namespace std;
int arr[100];
int vis[100];
int ans,k,z;
int flag;

void fun(int step,int m,int a)
{
int i;
if(step==k)
{
for (i=1;i<z;i++)
{
if(vis[i])
a %= arr[i];
if(a==0)
{flag=1;ans=step;return;}
}
}
for (i=m+1;i<z;i++)
{
vis[i]=1;
fun(step+1,i,a);
if(flag) return;
vis[i]=0;
}
}
int main()
{
int t,n,a,x,i;
scanf("%d",&t);
while (t--)
{
flag=0;z=1;
scanf("%d%d",&n,&a);
for ( i=1;i<=n;i++)
{
scanf("%d",&x);
if(x<=a) arr[z++]=x;
}
sort(arr+1,arr+z,cmp);
for (i=1;i<z;i++)
{
memset(vis,0,sizeof(vis));
k=i;
fun(0,-1,a);
if(flag) break;
}
if(!flag)
printf("-1\n");
else
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: