您的位置:首页 > 其它

hdu1241(Oil Deposits)

2015-08-02 21:01 316 查看
点击打开hdu1241

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.



Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.



Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.



Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0




Sample Output

0
1
2
2


题意:就是给你一个地图,找出所有不相连(八个方向)的@组合有多少个

解题思路:先对整个地图进行遍历,找到一个入口,然后用DFS深搜,相连的@都找到,并且将其标记为*(这样做的好处可以避免重新用visit对遍历过的地图进行标记)

import java.util.Scanner;
public class P1241 {
	public static int[][] dir={{1,0},{-1,0},{0,1},{0,-1},{-1,1},{-1,-1},{1,1},{1,-1}};//8个方向遍历
	public static char[][] map=new char[105][105];//地图
	public static int n,m;
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		String s;
		while(sc.hasNext()){
			n=sc.nextInt();
			m=sc.nextInt();
			int count=0;
			if(n==0&&m==0){
				break;
			}
			for(int i=0;i<n;i++){//输入map
				s=sc.next();
				map[i]=s.toCharArray();
			}
			for(int i=0;i<n;i++){//对map中的买个点进行深搜
				for(int j=0;j<m;j++){
					if(map[i][j]=='@'){//只要存在石油,然后通过这个石油入点找到的石油均属于同一块油田
						DFS(i,j);
						count++;
					}
				}
			}
			System.out.println(count);
		}
	}
	private static void DFS(int a, int b) {
		int x,y;
		for(int i=0;i<8;i++){
			x=a+dir[i][0];
			y=b+dir[i][1];
			if(x>=0&&x<n&&y>=0&&y<m&&map[x][y]=='@'){//朝八个方向进行深搜
				map[x][y]='*';//将遍历过的地方设置为*,这样就避免了重新定义一个visit标记有没有走过,从而达到优化
				DFS(x,y);
			}
		}
		
	}

}


广搜也可以:http://blog.csdn.net/u011479875/article/details/47282747
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: