您的位置:首页 > 其它

poj3280 区间dp

2015-08-02 18:31 288 查看
如题:http://poj.org/problem?id=3280

Cheapest Palindrome

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 6874Accepted: 3337
Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of
N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two
different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards).
Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding
a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤
cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so
it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input
Line 1: Two space-separated integers: N and
M

Line 2: This line contains exactly M characters which constitute the initial ID string

Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output
900

Hint
If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 +
350 = 900, which is the minimum.
Source
USACO 2007 Open Gold








思路:

区间dp

dp[i][j]表示区间[i,j]中变为回文串的最小花费。

if(str[i]==str[j])

dp[i][j]=dp[i+1][j-1].

else

dp[i][j]=min(dp[i+1][j]+cost[str[i]-'a'],dp[i][j-1]+cost[str[j]-'a'])



关于cost数组,删除和插入操作是等效的,所以cost数组只要取最小的那个操作。



#include<iostream>

#include<cstdio>

#include<cstring>

#include<string>

#define min(a,b)(a<b?a:b)

using namespace std;

int cost[26];

int dp[2005][2005];

int main()

{

// freopen("C:\\1.txt","r",stdin);

int n,m;

cin>>n>>m;

string s;

cin>>s;

int i,j;

for(i=0;i<n;i++)

{

char ch;

int a,b;

cin>>ch>>a>>b;

cost[ch-'a']=min(a,b);

}

for(i=2;i<=m;i++)

for(j=0;j<=m-i;j++)

{

if(s[j]==s[j+i-1])

dp[j][j+i-1]=dp[j+1][j+i-2];

else

dp[j][j+i-1]=min(dp[j+1][j+i-1]+cost[s[j]-'a'],dp[j][j+i-2]+cost[s[j+i-1]-'a']);

}

cout<<dp[0][m-1]<<endl;

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: