您的位置:首页 > 其它

POJ_1651_MultiplicationPuzzle

2015-08-02 16:28 330 查看
Multiplication Puzzle

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7071Accepted: 4354
Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on
the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output

Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5

Sample Output
3650

Source

Northeastern Europe 2001, Far-Eastern Subregion

区间dp第一题

dp[i][j]就是代表i到j这一段抽掉直到ij所能取得的最小值

因此两段合并时 dp[st][en]=min{dp[st][mi]+dp[mi][en]+num[st]*num[mi]*num[en]}

#include <iostream>
#include <stdio.h>
using namespace std;

const int M=105;
const int IN=M*100*100*100+100;
int num[M];
int dp[M][M];

int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=1;i<=n;i++)
scanf("%d",&num[i]);
for(int i=1;i<=n-2;i++)
dp[i][i+2]=num[i]*num[i+1]*num[i+2];
//cout<<"1"<<endl;
for(int l=4;l<=n;l++)
for(int st=1;st<=n-l+1;st++)
{
int co=IN;
int mul=num[st]*num[st+l-1];
for(int mi=st+1;mi<=st+l-2;mi++)
{
co=min(co,dp[st][mi]+dp[mi][st+l-1]+num[mi]*mul);
//cout<<st<<" "<<l<<" "<<mi<<" "<<co<<endl;
}
dp[st][st+l-1]=co;
}
printf("%d\n",dp[1]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: