您的位置:首页 > 其它

poj2385 dp

2015-08-02 13:08 232 查看
如题:http://poj.org/problem?id=2385

Apple Catching

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9298Accepted: 4528
Description
It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must
wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under
only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts
at tree 1.
Input
* Line 1: Two space separated integers: T and W

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.
Output
* Line 1: The maximum number of apples Bessie can catch without walking more than W times.
Sample Input
7 2
2
1
1
2
2
1
1

Sample Output
6

Hint
INPUT DETAILS:

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS:

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.
Source
USACO 2004 November






思路:dp[i][j][k]:在i时刻转了j次且在树k下能接到的最大苹果数

i∈[1,t] j∈[0,i] k∈[0,1]

递推关系:

if(j>0)

dp[i][j][k]=max(dp[i-1][j-1][(k+1)%2],dp[i-1][j][k])+第 i 时刻k树下有苹果?1:0

else

dp[i][j][k]=dp[i-1][j][k]+第 i 时刻k树下有苹果?1:0



#include<iostream>

#include<cstdio>

#include<cstring>

using namespace std;

#define max(a,b)(a>b?a:b)

int dp[1001][31][2];

int a[1001];

int main()

{

// freopen("C:\\1.txt","r",stdin);

int t,w;

cin>>t>>w;

int i,j,k;

for(i=1;i<=t;i++)

cin>>a[i];

for(i=1;i<=t;i++)

for(j=0;j<=i;j++)

for(k=0;k<=1;k++)

{

int x=0;

if(j>0)

x=max(x,dp[i-1][j-1][(k+1)%2]);

x=max(x,dp[i-1][j][k]);

if(a[i]-1==k)

x++;

dp[i][j][k]=x;

}

int res=0;

for(i=0;i<=w;i++)

{

int x=max(dp[t][i][0],dp[t][i][1]);

res=max(res,x);

}

cout<<res<<endl;

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: