您的位置:首页 > 其它

hdu 4355 Party All the Time 典型三分

2015-08-02 10:13 507 查看


Party All the Time

Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 65536/32768
K (Java/Others)



Problem Description

In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long
way.According to our observation,a spirit weighing W will increase its unhappyness for S3*W units if it walks a distance of S kilometers.

Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

Input

The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x[i]<=x[i+1] for
all i(1<=i<N). The i-th line contains two real number : Xi,Wi, representing the location and the weight of the i-th spirit. ( |xi|<=106, 0<wi<15 )

Output

For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.

Sample Input

1
4
0.6 5
3.9 10
5.1 7
8.4 10


Sample Output

Case #1: 832


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4355

分析:
F(x) = sigma |xi – x|^3*w;
求导后发现是一个凸性函数,其实可以YY,然后三分搞一下就可以了。

刚开始以为是上凸,结果老是不对,否来发现是下凸;
代码如下:
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
double p[50010],w[50010];
const double eps=1e-5;
int n;
double cal(double x)
{
double ans=0;
for(int i=0; i<n; i++)
{
double s=fabs(p[i]-x);
ans+=s*s*s*w[i];
}
return ans;
}
double solve(double l,double r)
{
double mid,d1,d2;
double midmid;
while(r-l>eps)
{
mid=(l+r)/2;
midmid=(mid+r)/2;
d1=cal(mid);
d2=cal(midmid);
if(d1<=d2) r=midmid;
else
l=mid;
}
return l;

}
int main()
{
int t;
scanf("%d",&t);
int cnt=1;
while(t--)
{
scanf("%d",&n);
double r=-10000000;
double l=100000000;
for(int i=0; i<n; i++)
{
scanf("%lf%lf",&p[i],&w[i]);
if(p[i]>r) r=p[i];
if(p[i]<l) l=p[i];
}
printf("Case #%d: %.0lf\n",cnt++,cal(solve(l,r)));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: