您的位置:首页 > 其它

九度oj 1444

2015-08-01 21:46 232 查看
题目描述:

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys.
The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect),
or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
输入:

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct
friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
输出:

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
样例输入:
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

样例输出:
4
2

#include<iostream>
#include<stdio.h>
using namespace std;
#define N 10000001
int tree
;
int findroot(int x)
{
if(tree[x]==-1)
return x;
else
return findroot(tree[x]);
}
int sum
;
int main()
{
int n;
while(cin>>n)
{
memset(tree,-1,sizeof(tree));
for(int i=1;i<N;i++)
{
tree[i]==-1;
sum[i]=1;
}
while(n--!=0)
{
int a,b;
cin>>a>>b;
a=findroot(a);
b=findroot(b);
if(a!=b)
{
tree[a]=b;
sum[b]+=sum[a];
}
}
int ans=1;
for(int i=1;i<=N;i++)
{
if(tree[i]==-1&&sum[i]>ans)
{
ans=sum[i];}
}
cout<<ans<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: