您的位置:首页 > 其它

hdoj.5115 Dire Wolf【区间DP】 2015/08/01

2015-08-01 16:12 495 查看

Dire Wolf

Time Limit: 5000/5000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 716 Accepted Submission(s): 412

[align=left]Problem Description[/align]
Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.

Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that
look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.

Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.

— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by bi. Thus, each dire wolf i’s current attack consists of two parts,
its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent
to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks bi they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second
wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.

[align=left]Input[/align]
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers ai (0 ≤ ai ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers bi (0 ≤ bi ≤ 50000), denoting the extra attack each dire wolf can provide.

[align=left]Output[/align]
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.

[align=left]Sample Input[/align]

2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1


[align=left]Sample Output[/align]

Case #1: 17
Case #2: 74

HintIn the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.


[align=left]Source[/align]
2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

注:区间DP,状态转移方程:dp[i][j] = min(dp[i][j],dp[i][k-1]+dp[k+1][j]+a[i]+b[i-1]+b[j+1]);
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>

using namespace std;

#define INF 0x3f3f3f3f
int t,n,a[210],b[210];
int dp[210][210];

int min(int a,int b){
return a>b?b:a;
}

int main(){
cin>>t;
int ans = 1;
while(t--){
cin>>n;
memset(a,-1,sizeof(a));
memset(b,0,sizeof(b));
memset(dp,0,sizeof(dp));
for( int i = 1 ; i <= n ; ++i )
scanf("%d",&a[i]);
for( int i = 1; i <= n ; ++i )
scanf("%d",&b[i]);
for( int l = 0 ; l < n ; ++l ){
for( int i = 1 ; i <= n ; ++i ){
int j = i + l;
if( j == i ){
dp[i][j] = a[i] + b[i-1] + b[i+1];
continue;
}
if( j > n ) break;
dp[i][j] = min(a[i]+dp[i+1][j],a[j]+dp[i][j-1]);
for( int k = i + 1 ; k < j ; ++k )
dp[i][j] = min(dp[i][j],dp[i][k-1]+dp[k+1][j]+a[k]);
dp[i][j] += b[i-1] + b[j+1];
}
}
printf("Case #%d: %d\n",ans++,dp[1]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: