您的位置:首页 > 其它

PAT (Advanced Level) 1098. Insertion or Heap Sort (25) 直插和堆排

2015-08-01 10:31 435 查看
According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts
it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than
a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed
that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that
the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

对第一个数组进行堆排,看途中能否得到第二个数组。
/*2015.8.1cyq*/
#include <iostream>
#include <vector>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

//将以root为根的树调整为大根堆,前提是左右子树都是大根堆
void adjustDown(vector<int> &a,int root,int n){
a[0]=a[root];
for(int i=2*root;i<=n;i*=2){
if(i<n&&a[i]<a[i+1])
i++;//较大子结点
if(a[0]>a[i])
break;
else{
a[root]=a[i];
root=i;
}
}
a[root]=a[0];
}
//建立大根堆
void buildMaxHeap(vector<int> &a,int n){
for(int i=n/2;i>0;i--)
adjustDown(a,i,n);
}

int main(){
int N;
cin>>N;
vector<int> a(N+1),b(N+1);//a[0]作为堆排的辅助
for(int i=1;i<=N;i++)
cin>>a[i];
for(int i=1;i<=N;i++)
cin>>b[i];
b[0]=0;

bool isHeapSort=false;
buildMaxHeap(a,N);
int i;
for(i=N;i>1;i--){//堆排
swap(a[i],a[1]);
adjustDown(a,1,i-1);
a[0]=0;
if(a==b){
isHeapSort=true;
break;
}
}
if(isHeapSort){
i--;
swap(b[i],b[1]);
adjustDown(b,1,i-1);
cout<<"Heap Sort"<<endl;
}else{//直接插入排序
int j=2;
while(j<N&&b[j]>=b[j-1])
j++;
int tmp=b[j];
int k=j-1;
while(k>=0&&b[k]>tmp){
b[k+1]=b[k];
k--;
}
b[k+1]=tmp;
cout<<"Insertion Sort"<<endl;
}
cout<<b[1];
for(int j=2;j<=N;j++)
cout<<" "<<b[j];
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: