您的位置:首页 > 其它

HDU_5327_Olympiad

2015-07-31 21:58 274 查看

Olympiad

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 428 Accepted Submission(s): 308



[align=left]Problem Description[/align]
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not
beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval
[a,b] (a≤b).
Please be fast to get the gold medal!

[align=left]Input[/align]
The first line of the input is a single integer
T (T≤1000),
indicating the number of testcases.

For each test case, there are two numbers a
and b,
as described in the statement. It is guaranteed that
1≤a≤b≤100000.

[align=left]Output[/align]
For each testcase, print one line indicating the answer.

[align=left]Sample Input[/align]

2
1 10
1 1000


[align=left]Sample Output[/align]

10
738


[align=left]Author[/align]
XJZX

[align=left]Source[/align]
2015 Multi-University Training Contest 4

[align=left]Recommend[/align]
wange2014

题目描述有重复数字的数不是美丽的数

求某区间中美丽的数的个数

预处理下全部的数字,像筛法求素数一样即可

#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;

const int M=100005;
int num[M];
int nn[7];

int main()
{
int t;
int a,b;
scanf("%d",&t);
for(int i=10;i<M;i++)
{
if(num[i])
continue;
int ti=i;
int p=0;
int f=1;
int ws=0;
while(ti>0)
{
nn[p]=ti%10;

ti/=10;
for(int j=0;j<p;j++)
if(nn[j]==nn[p])
{
num[i]=1;
f=0;
break;
}
p++;
ws++;
}
if(!f)
{
int dn=pow(10,ws);
for(int j=dn+i;j+i<M;j+=dn)
num[j]=1;
}
}

while(t--)
{
int co=0;
scanf("%d%d",&a,&b);
for(int i=a;i<=b;i++)
if(!num[i])
co++;
printf("%d\n",co);
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: