您的位置:首页 > 其它

哈理工2015暑假训练赛BNU16488 Easy Task(简单题)

2015-07-31 21:42 316 查看
A - Easy Task
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%lld
& %llu
SubmitStatusPracticeZOJ
2969

Description

Calculating the derivation of a polynomial is an easy task. Given a function f(x) , we use (f(x))' to denote its derivation. We use x^n to denote xn. To calculate the derivation of a polynomial, you should know 3 rules:


(1) (C)'=0 where C is a constant.

(2) (Cx^n)'=C*n*x^(n-1) where n>=1 and C is a constant.

(3) (f1(x)+f2(x))'=(f1(x))'+(f2(x))'.

It is easy to prove that the derivation a polynomial is also a polynomial.

Here comes the problem, given a polynomial f(x) with non-negative coefficients, can you write a program to calculate the derivation of it?

Input

Standard input will contain multiple test cases. The first line of the input is a single integer
T (1 <= T <= 1000) which is the number of test cases. And it will be followed by
T consecutive test cases.

There are exactly 2 lines in each test case. The first line of each test case is a single line containing an integer
N (0 <= N <= 100). The second line contains N + 1 non-negative integers,
CN, CN-1, ..., C1,
C0, ( 0 <= Ci <= 1000), which are the coefficients of f(x).
Ci is the coefficient of the term with degree i in f(x). (CN!=0)

Output

For each test case calculate the result polynomial g(x) also in a single line.

(1) If g(x) = 0 just output integer 0.otherwise

(2) suppose g(x)= Cmx^m+Cm-1x^(m-1)+...+C0 (Cm!=0),then output the integers
Cm,Cm-1,...C0.

(3) There is a single space between two integers but no spaces after the last integer.

Sample Input

3
0
10
2
3 2 1
3
10 0 1 2


Sample Output
0
6 2
30 0 1

现场秒杀题。不解释。

#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
int main()
{
    int cnt[10000];
    int t;cin>>t;
    while(t--)
    {
        int n;cin>>n;

        for(int i=0;i<=n;i++)
        {
            scanf("%d",&cnt[i]);
        }
        if(n==0)
        {

            cout<<0<<endl;continue;
        }
        int x=n;

        cout<<cnt[0]*x;x--;
        for(int i=1;i<n;i++)
        {
            cout<<" "<<cnt[i]*x;
            x--;
        }
        cout<<endl;

    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: