您的位置:首页 > 其它

HDU 5224 Tom and paper

2015-07-31 19:15 363 查看

Problem Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper.

T≤10,n≤109

Output

For each case, output a integer, indicates the answer.

Sample Input

3

2

7

12

Sample Output

6

16

14

题意:给定矩形纸片的面积,求出最少的周长


//代码实现
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
long long n;
long long len,x;
scanf("%lld",&n);
for(int i=1;i<=sqrt(n);i++) //sqrt(n)可以缩小循环的范围
{
if(n%i==0)//找出符合条件的长
{
x=n/i;
len=2*(i+x);//求出最小的周长

}

}
printf("%lld\n",len);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: