您的位置:首页 > 其它

ZOJ_1093_MonkeyAndBanana

2015-07-31 18:10 288 查看
Monkey and Banana

Time Limit: 2 Seconds Memory Limit: 65536 KB

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks.
If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi,
yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another
block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to
have equal-sized bases couldn't be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input Specification

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is
30.

Each of the next n lines
contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

Output Specification

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case:
maximum height = height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


Source: University of Ulm Local Contest 1996

题目中每个砖头可以用长宽高组合成6种砖头,排序长和宽变成3种

完全背包问题只是没给出背包大小,但是根据砖块不能放在自己种类的头上

因此最大高度不会超过种类

只要搜索总种类以内的情况就可以了

dp[i][j]为i层(可能不够i层但是也可想想上面的层数高度是0)高以j种砖头为底的最大高度

//ÍêÈ«±³°ü
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int M=35;
int bl[M*3][3];
int dp[M*3][M*3];

void swap(int &a,int &b)
{
int t=a;
a=b;
b=t;
}

int main()
{
int n;
int ca=1;
while(1)
{
scanf("%d",&n);
if(!n)
break;
for(int i=1;i<=3*n;i+=3)
{
scanf("%d%d%d",&bl[i][0],&bl[i][1],&bl[i][2]);
if(bl[i][0]>bl[i][1])
swap(bl[i][0],bl[i][1]);
bl[i+1][0]=bl[i][1];bl[i+1][1]=bl[i][2];bl[i+1][2]=bl[i][0];
if(bl[i+1][0]>bl[i+1][1])
swap(bl[i+1][0],bl[i+1][1]);
bl[i+2][0]=bl[i][2];bl[i+2][1]=bl[i][0];bl[i+2][2]=bl[i][1];
if(bl[i+2][0]>bl[i+2][1])
swap(bl[i+2][0],bl[i+2][1]);
}
int mh;
for(int i=1;i<=3*n;i++)
dp[1][i]=bl[i][2];
for(int i=2;i<=3*n;i++)
{
for(int j=1;j<=3*n;j++)
{
mh=0;
for(int k=1;k<=3*n;k++)
if(bl[k][0]<bl[j][0]&&bl[k][1]<bl[j][1])
mh=max(mh,dp[i-1][k]);
dp[i][j]=mh+bl[j][2];
//cout<<"i "<<i<<"j "<<j<<"dp "<<dp[i][j]<<endl;
}
}
mh=0;
for(int i=1;i<=3*n;i++)
mh=max(mh,dp[3*n][i]);
printf("Case %d: maximum height = %d\n",ca,mh);
ca++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: