您的位置:首页 > 产品设计 > UI/UE

POJ 3080 Blue Jeans(字符串处理)

2015-07-31 15:23 447 查看
Blue Jeans

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 14076Accepted: 6249
Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.
Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences
of the same longest length exist, output only the subsequence that comes first in alphabetical order.
Sample Input
3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output
no significant commonalities
AGATAC
CATCATCAT

求k个长度为60的字符串的最长连续公共子串要求  最长公共串长度大于3, 如果出现等长的子串,输出字典序最小的直接暴就可以了,对字符串这些处理函数又学了遍。。。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <queue>
#include <string>
#define N 60
using namespace std;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        string a[11];
        for(int i=0; i<n; i++)
            cin>>a[i];
        string ans="";
        for(int i=0; i<N-2; i++)      //找出a[0]的所有的子串,在a[2~n-1]中挨个匹配
        {
            for(int j=3; j<=N; j++)          //子串的长度为[3,60];
            {
                string ss=a[0].substr(i,j);   // 现在才理解这个函数,以前都理解错了,
                bool flag=true;               //从i开始截取j个字符
                for(int k=1; k<n; k++)
                {
                    if(a[k].find(ss)==string::npos)     //ss在a[k]中找不到
                    {
                        flag=false;
                        break;
                    }
                }
                if(flag && ans.length() < ss.length())
                    ans=ss;
                else if(flag && ans.length() == ss.length() && ans > ss)
                    ans=ss;
            }
        }
        if(ans == "")
            printf("no significant commonalities\n");
        else cout << ans << endl;
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: