您的位置:首页 > 其它

Hduoj1033【水题】

2015-07-31 10:19 295 查看
/*Edge
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2406    Accepted Submission(s): 1534

Problem Description
For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is 
folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel 
to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the 
surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle 
that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet. 
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding 
the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve 
in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type 
V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet 
assuming 90 degree turns at equidistant places.

Input
The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V 
describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file 
terminates immediately after the last test case.

Output
For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the 
coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto"
. Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands 
with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the 
edge and finish each test case by the commands stroke and showpage. 

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.
 
Sample Input
V
***V
 

Sample Output
300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage
 

Source
University of Ulm Local Contest 2003 
 

Recommend
We have carefully selected several similar problems for you:  1035 1036 1039 1062 1046 
*/ 
#include<stdio.h>
#include<string.h>
int dir;
char s[210];
int main()
{
	int i, j, k, l;
	while(gets(s) != NULL)
	{
		l = strlen(s);
		dir = 2;
		printf("300 420 moveto\n310 420 lineto\n");
		int x = 310, y = 420;
		for(i = 0; i < l; ++i)
		{
				if(dir == 1)
				{
					if(s[i] == 'A')
					{
						x -= 10;
						dir = 4;
					}
					else
					{
						x += 10;
						dir = 2;
					}
				}
				else if(dir == 2)
				{
					if(s[i] == 'A')
					{
						y -= 10;
						dir = 1;
					}
					else
					{
						y += 10;
						dir = 3;
					}
				}
				else if(dir == 3)
				{
					if(s[i] == 'A')
					{
						x += 10;
						dir = 2;
					}
					else
					{
						x -= 10;
						dir = 4;
					}
				}
				else
				{
					if(s[i] == 'A')
					{
						y += 10;
						dir = 3;
					}
					else
					{
						y -= 10;
						dir = 1;
					}
				}
				printf("%d %d lineto\n", x, y);
		}
		printf("stroke\nshowpage\n");
	}
	return 0;
}


题意:以300,420 为起点,每移动一步为10个单位,第一步一定是300,420到310,420,现在输入一个字符串,只包含A和V,A代表向顺时针方向移动,V代表向逆时针方向移动,按照他给的格式输出路径就是了,说白了就是个水题。

思路:用一个变量标记方向,逐个字符判断移动,并每次都要更新方向。

难点:这题最大的难题就是读题。。。。基本上是读不懂,只能看测试数据慢慢领悟了。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: