您的位置:首页 > 大数据 > 人工智能

PAT (Advanced Level) 1090. Highest Price in Supply Chain (25) 供应链,BFS

2015-07-31 09:02 591 查看
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root
supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price
given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for
the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the
price will not exceed 1010.
Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:
1.85 2

建树后(每个结点记录其后继结点),进行BFS,记录当前层数和当前层结点数用于输出。

/*2015.7.30cyq*/
#include <iostream>
#include <queue>
#include <vector>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

int main(){
int N;
double P,r;
cin>>N>>P>>r;

int root=0;
int x;
vector<vector<int> > tree(N);//tree[x]存储x的后继结点
for(int i=0;i<N;i++){
cin>>x;
if(x==-1)
root=i;
else{
tree[x].push_back(i);
}
}
//BFS
queue<int> cur,next;
cur.push(root);
int level=0;		//当前层
int levelCount=0;	//当前层的结点数
while(!cur.empty()){
level++;
levelCount=cur.size();
while(!cur.empty()){
int tmp=cur.front();
cur.pop();
for(auto it=tree[tmp].begin();it!=tree[tmp].end();++it){
next.push(*it);
}
}
swap(cur,next);
}
for(int i=1;i<level;i++)
P=P*(1+r/100);
printf("%.2f %d",P,levelCount);
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: