您的位置:首页 > 其它

Catch That Cow(POJ--

2015-07-31 08:51 411 查看
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0
≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
题意:John 与牛在一条直线上,John和牛有各自的坐标,John走一步其坐标可以退一个格也可以前进一个格也可以直接蹦到他所在坐标的两倍的格子,问John至少要走几步才能追上牛。
Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include <cstdio>
#include <queue>
#include <cstring>
#define MAX 100002
using namespace std;
int n,k,cnt;
bool vis[MAX];
int num[MAX];                                    //记录到某坐标的步数
void BFS()
{
queue<int>ww;
ww.push(n);                                   //先把本身坐标押进队列中
vis
=true;                                    //先把本身坐标进行标记以防重走
int x;
while(!ww.empty())
{
x=ww.front();                             //取出队首开始进行遍历
ww.pop();
if(x==k)
{
printf("%d\n",num[x]);
return ;
}
if(x-1>=0&&x-1<MAX&&!vis[x-1])
{
vis[x-1]=true;                            <span style="font-family: Arial, Helvetica, sans-serif;">//如果后退一格合法且没走过的情况下,标记前一格且将前一格押进队列中且前一格的步数等于该格步数+1。</span>
ww.push(x-1);
num[x-1]=num[x]+1;
}
if(x+1>=0&&x+1<MAX&&!vis[x+1])
{
vis[x+1]=true;                           <span style="font-family: Arial, Helvetica, sans-serif;">//如果前进一格合法且没走过的情况下,标记后一格且将后一格押进队列中且后一格的步数等于该格步数+1。</span>
ww.push(x+1);
num[x+1]=num[x]+1;
}
if(x*2>=0&&x*2<MAX&&!vis[x*2])
{
vis[x*2]=true;                          <span style="font-family: Arial, Helvetica, sans-serif;">//同上</span>
ww.push(x*2);
num[x*2]=num[x]+1;
}
}
}
int main()
{
while(~scanf("%d %d",&n,&k))
{
memset(num,0,sizeof(num));
memset(vis,0,sizeof(vis));
BFS();
}
}<strong>
</strong>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: