您的位置:首页 > 其它

HDOJ 1162 Eddy's picture(最小生成树--kruskal)

2015-07-30 20:10 405 查看

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8026    Accepted Submission(s): 4060


[align=left]Problem Description[/align]
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it
can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?

 

[align=left]Input[/align]
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

 

[align=left]Output[/align]
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

 

[align=left]Sample Input[/align]

3
1.0 1.0
2.0 2.0
2.0 4.0

 

[align=left]Sample Output[/align]

3.41

 

就是求这几个点连在一起的最短距离和

ac代码:
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define MAXN 1000100
using namespace std;
int pri[MAXN];
struct s//左边
{
float x;
float y;
}locate[MAXN];
struct ss//节点
{
float begin;
float end;
float distance;
}num[MAXN];
bool cmp(ss a,ss b)
{
return a.distance<b.distance;
}
int find(int x)
{
int r=x;
while(r!=pri[r])
r=pri[r];
return r;
}
int main()
{
int n,i,j;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
scanf("%f%f",&locate[i].x,&locate[i].y);
int sum=0;
for(i=0;i<n;i++)
{
for(j=i+1;j<n;j++)
{
num[sum].begin=i+1;//节点始末存入
num[sum].end=j+1;
num[sum].distance=sqrt((locate[i].x-locate[j].x)*(locate[i].x-locate[j].x)+(locate[i].y-locate[j].y)*(locate[i].y-locate[j].y));//距离存入
sum++;
}
}
for(i=1;i<=n;i++)
pri[i]=i;
sort(num,num+sum,cmp);
float max=0;
for(i=0;i<sum;i++)
{
int nx=find(num[i].begin);
int ny=find(num[i].end);
if(nx!=ny)
{
pri[nx]=ny;
max+=num[i].distance;
}
}
printf("%.2f\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: