您的位置:首页 > 其它

2015 多校联赛 ——HDU5294(最短路,最小切割)

2015-07-30 20:06 465 查看


Tricks Device

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1977 Accepted Submission(s): 509



Problem Description

Innocent Wu follows Dumb Zhang into a ancient tomb. Innocent Wu’s at the entrance of the tomb while Dumb Zhang’s at the end of it. The tomb is made up of many chambers, the total number is N. And there are M channels connecting the chambers. Innocent Wu wants
to catch up Dumb Zhang to find out the answers of some questions, however, it’s Dumb Zhang’s intention to keep Innocent Wu in the dark, to do which he has to stop Innocent Wu from getting him. Only via the original shortest ways from the entrance to the end
of the tomb costs the minimum time, and that’s the only chance Innocent Wu can catch Dumb Zhang.

Unfortunately, Dumb Zhang masters the art of becoming invisible(奇门遁甲) and tricks devices of this tomb, he can cut off the connections between chambers by using them. Dumb Zhang wanders how many channels at least he has to cut to stop Innocent Wu. And Innocent
Wu wants to know after how many channels at most Dumb Zhang cut off Innocent Wu still has the chance to catch Dumb Zhang.



Input

There are multiple test cases. Please process till EOF.

For each case,the first line must includes two integers, N(<=2000), M(<=60000). N is the total number of the chambers, M is the total number of the channels.

In the following M lines, every line must includes three numbers, and use ai、bi、li as channel i connecting chamber ai and bi(1<=ai,bi<=n), it costs li(0<li<=100) minute to pass channel i.

The entrance of the tomb is at the chamber one, the end of tomb is at the chamber N.



Output

Output two numbers to stand for the answers of Dumb Zhang and Innocent Wu’s questions.



Sample Input

8 9
1 2 2
2 3 2
2 4 1
3 5 3
4 5 4
5 8 1
1 6 2
6 7 5
7 8 1




Sample Output

2 6




Author

FZUACM



Source

2015 Multi-University Training Contest 1

题意:

n个点,m条边,构建有权无向图。

求出删去最少条边数可以使得图没有最短路径,以及删出最多条边使得图仍有最多条路径。

思路:

最短路处理出最短路径图,做法是使用dis数组,若若dis[v]-dis[u] = w(u,v),则该路在最短路径中。

建出最短路径之后 跑一次网络流,得到第一个答案。

在跑最短路中记录最短路的最少路数,ans2 = m - minb.

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
#include<cmath>
#include<map>
#include<queue>
using namespace std;
const int N=2005;
const int MAXN=(1<<31)-1;
int INF=0x7f7f7f7f;
 int T,n,m,k,tot;
 int cas=1;
 int head
;
 struct Edge{
    int to,w,next;
 }edge[60005*2];
 void addedge(int u,int v,int w){
    edge[tot].to=v;
    edge[tot].w=w;
    edge[tot].next=head[u];
    head[u]=tot++;

    edge[tot].to=u;
    edge[tot].w=w;
    edge[tot].next=head[v];
    head[v]=tot++;
 }

 int dis
,vis
;
 int minb
;
 int spfa(int s){
    memset(dis,0x3f,sizeof dis);
    memset(vis,0,sizeof vis);
    memset(minb,0x3f,sizeof minb);

    queue<int> q;
    dis[s]=0;
    minb[s]=0;
    vis[s]=1;
    q.push(s);

    while(!q.empty()){
        int u=q.front();q.pop();
        vis[u]=0;

        for(int i=head[u];~i;i=edge[i].next){
           int v=edge[i].to,w=edge[i].w;
           if(dis[v]==dis[u]+w){
                minb[v]=min(minb[v],minb[u]+1);
                if(!vis[v]){
                    vis[v]=1;
                    q.push(v);
                }
           }

           if(dis[v]>dis[u]+w){
                dis[v]=dis[u]+w;
                minb[v]=minb[u]+1;
                if(!vis[v]){
                    vis[v]=1;
                    q.push(v);
                }
           }

        }
    }
 }
 struct Eg{
    int u,cap,rev;
    Eg(int uu,int cc,int rr){
        u=uu;cap=cc;rev=rr;
    }
 };
 vector<Eg> G
;
 void add(int u,int v,int cap){
    G[u].push_back(Eg(v,cap,G[v].size()));
    G[v].push_back(Eg(u,0,G[u].size()-1));
 }

 void build(){
    for(int i=1;i<=n;i++){
        for(int j=head[i];~j;j=edge[j].next){
            int v=edge[j].to,w=edge[j].w;
            if(dis[v]==dis[i]+w){
                add(i,v,1);

            }
        }
    }
 }
 bool used
;
 int dfs(int v,int t,int f){
    if(v==t) return f;
    used[v]=true;
    for(int i=0;i<G[v].size();i++){
        Eg &e=G[v][i];
        if(!used[e.u] && e.cap>0){
            int d=dfs(e.u,t,min(f,e.cap));
            if(d>0){
                e.cap-=d;
                G[e.u][e.rev].cap+=d;
                return d;
            }
        }
    }
    return 0;
 }
 int max_flow(int s,int t){
  int flow=0;
  while(1){
    memset(used,0,sizeof used);
    int f=dfs(s,t,INF);
    if(f==0) return flow;
    flow+=f;
  }
 }
  void init(){
    tot=0;
    memset(head,-1,sizeof head);
    for(int i=0;i<N;i++) G[i].clear();
 }
int main()
{
#ifndef  ONLINE_JUDGE
   freopen("aaa","r",stdin);
#endif

    while(~scanf("%d%d",&n,&m)){
        init();
        for(int i=0;i<m;i++){
            int u,v,w;
            scanf("%d %d %d",&u,&v,&w);
            addedge(u,v,w);
        }
        spfa(1);

        build();
        int ans=max_flow(1,n);
        printf("%d %d\n",ans,m-minb
);
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: