您的位置:首页 > 其它

Orders Poj

2015-07-30 19:35 267 查看
Orders

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 9911Accepted: 6028
Description
The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this
letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking.

You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece
during the day.

Input
Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders
doesn't exceed 200.

Output
Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods.
Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes.

Sample Input
bbjd

Sample Output
bbdj
bbjdbdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
int l;char s[1000];
cin>>s;
l=strlen(s);
sort(s,s+l);
cout<<s<<endl;
while(next_permutation(s,s+l))//考察的STL中用next_permutation(s,s+l)对字符串排序的功能;注意不仅仅如此还有sort的使用
 cout<<s<<endl;
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: