您的位置:首页 > 其它

杭电1213 How Many Tables(并查集找根节点)

2015-07-30 15:06 459 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18215 Accepted Submission(s): 8975



Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.



Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.



Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.



Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5




Sample Output
2
4


题目意思没弄懂,听学长讲的,求根节点,那就简单了

#include<cstdio>
int per[1010];
void abs()
{
	for(int i=0;i<1010;i++)//把一个个输入的数的根节点都初始为本身 
	per[i]=i;
}
int find(int x)//查找每个输入值的根节点并压缩 
{
	int r;
	r=x;
	while(r!=per[r])
	r=per[r];
	int j,i;
	i=x;
	while(i!=r)
	{
		j=per[i];
		per[i]=r;
		i=j;
	}
	return r;
}
void join(int x,int y)//如果根节点不同,则把他们并在一个根节点上 
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
	per[fx]=fy;
}
int find_ans(int n)//查找根节点有多少的函数; 
{   int i,sum;
	sum=0;
	for(i=1;i<=n;i++)
	{
	if(i==per[i])
	sum++;
	}
	return sum;
}
int main()
{
	int n,i,a,b,test,m;
	scanf("%d",&test);
		while(test--)
		{
			scanf("%d%d",&n,&m);
			abs();//每个n都变成根节点 
		for(i=0;i<m;i++)                             
		{
			scanf("%d %d",&a,&b); //每组啊,a,b寻根并集                                                                                                                                                                                      
			join(a,b);
		} 
		printf("%d\n",find_ans(n));//看看有几根根节点 
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: