您的位置:首页 > 其它

PAT (Advanced Level) 1084. Broken Keyboard (20) 坏键盘,字符串处理

2015-07-30 14:42 411 查看
On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital
numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.
Sample Input:
7_This_is_a_test
_hs_s_a_es

Sample Output:
7TI

/*2015.7.30cyq*/
#include <iostream>
#include <string>
#include <vector>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

int main(){
string s1,s2,res;
cin>>s1>>s2;
int n=s1.size();
int m=s2.size();
int i=0,j=0;
while(i<n&&j<m){
if(s1[i]!=s2[j]){
res+=s1[i];
i++;
}else{
i++;
j++;
}
}
while(i<n)
res+=s1[i++];

vector<bool> visited(256,false);
for(auto it=res.begin();it!=res.end();++it){
char tmp=toupper(*it);
if(!visited[tmp]){
visited[tmp]=true;
cout<<tmp;
}
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: