您的位置:首页 > 其它

POJ 3784 Running Median

2015-07-30 10:32 323 查看
Running Median

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1511 Accepted: 748
Description

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.
Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving
the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.
Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated
by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.
Sample Input
3
1 9
1 2 3 4 5 6 7 8 9
2 9
9 8 7 6 5 4 3 2 1
3 23
23 41 13 22 -3 24 -31 -11 -8 -7
3 5 103 211 -311 -45 -67 -73 -81 -99
-33 24 56

Sample Output
1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3
-7 -3


AC代码

#include<algorithm>
#include<string>
#include<cmath>
#include<cstdio>

void run()
{
int n,m;
scanf("%d%d",&n,&m);
int i,num[10001];
int ans[10001]={0};
int u = 2;

printf("%d %d\n",n,(m+1)/2);
scanf("%d",&num[1]);
ans[1]=num[1];
for(i=2;i<=m;i++)
{
int tmp,j,k;
scanf("%d",&tmp);
if(tmp<=num[1]) //比第一个小,则后面的往后移
{
for(k=i-1;k>=1;k--)
{
num[k+1]=num[k];
}
num[1]=tmp;
}

else if(tmp>=num[i-1]) //比最后一个大
{
num[i]=tmp;
}
else
{
bool f=false;
for(j=i-1;j>=1;j--)
{
if(tmp>=num[j-1] && tmp<=num[j]) //找要插入的位置位置
{
f=true;
int k;
for(k=i-1;k>=j;k--)
{
num[k+1]=num[k];
}
num[j]=tmp;
}
if(f==true)
break;
}
}
if(i%2==1) //记录奇数位置
{
ans[u++]=num[(i+1)/2];
}
}
for(i=1;i<u;i++)
{
if(i%10==0 || i==u-1)
printf("%d\n",ans[i]);
else
printf("%d ",ans[i]);
}
}

int main()
{
int total;
scanf("%d",&total);
for(int now=1;now<=total;now++)
run();

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: