您的位置:首页 > 其它

HDOJ-1213 How Many Tables(包含题意)

2015-07-30 10:10 393 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18187 Accepted Submission(s): 8957



Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.



Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.



Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.



Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5




Sample Output
2
4
题意:小明过生日,到了吃饭的时候,一群人过来吃饭,小明必须保证 认识的人在一张桌子上,朋友的朋友就是认识的人,对于并查集来说就是拥有同一个祖先的就是一群朋友咯,这道题就是判断有多少个祖先。换句话说,也就是有多少棵树。
我的代码:
#include<stdio.h>
int per[1010];
int n,m;
void init(int m){
	for(int i=1;i<=n;i++)
		per[i]=i;
}
int find(int x){
	int r=x;
	while(r!=per[r])
		r=per[r];
	int i=x,j;
	while(i!=r){
		j=per[i];
		per[i]=r;
		i=j;
	}
	return r;
}
void join(int a,int b){
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
		per[fa]=fb;
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int count=0;
		scanf("%d%d",&n,&m);
		init(n);
		while(m--){
			int a,b;
			scanf("%d%d",&a,&b);
			join(a,b);
		}
		for(int i=1;i<=n;i++)
			if(per[i]==i)
				count++;
		printf("%d\n",count);
	}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: