您的位置:首页 > 其它

HDOJ 3592 World Exhibition 差分约束

2015-07-30 09:09 323 查看


World Exhibition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1373    Accepted Submission(s): 673


Problem Description

Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the
same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes
which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.

 

Input

First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y. 

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.

 

Output

For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.

 

Sample Input

1
4 2 1
1 3 8
2 4 15
2 3 4

 

Sample Output

19

 

Author

alpc20

 

Source

2010 ACM-ICPC Multi-University
Training Contest(15)——Host by NUDT

 

/* ***********************************************
Author :CKboss
Created Time :2015年07月30日 星期四 08时16分29秒
File Name :HDOJ3592.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int maxn=1111;
const int INF=0x3f3f3f3f;

struct Edge
{
int to,next,cost;
}edge[30300];

int Adj[maxn],Size;

void init()
{
memset(Adj,-1,sizeof(Adj)); Size=0;
}

void Add_Edge(int u,int v,int c)
{
edge[Size].to=v;
edge[Size].cost=c;
edge[Size].next=Adj[u];
Adj[u]=Size++;
}

int n,m1,m2;

int dist[maxn],cq[maxn];
bool inq[maxn];

bool spfa(int rt)
{
memset(dist,63,sizeof(dist));
memset(cq,0,sizeof(cq));
memset(inq,false,sizeof(inq));

dist[rt]=0;
queue<int> q;
inq[rt]=true; q.push(rt); cq[rt]=1;

while(!q.empty())
{
int u=q.front(); q.pop();

for(int i=Adj[u];~i;i=edge[i].next)
{
int v=edge[i].to;
if(dist[v]>dist[u]+edge[i].cost)
{
dist[v]=dist[u]+edge[i].cost;
if(!inq[v])
{
inq[v]=true;
cq[v]++;
if(cq[v]>=n) return false;
q.push(v);
}
}
}
inq[u]=false;
}
return true;
}

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);

int T_T;
scanf("%d",&T_T);
while(T_T--)
{
scanf("%d%d%d",&n,&m1,&m2);
init();
int u,v,c;
for(int i=0;i<m1;i++)
{
scanf("%d%d%d",&u,&v,&c);
Add_Edge(u,v,c);
}
for(int i=0;i<m2;i++)
{
scanf("%d%d%d",&u,&v,&c);
Add_Edge(v,u,-c);
}

bool fg=spfa(1);
if(fg==false) puts("-1");
else if(dist
==INF) puts("-2");
else printf("%d\n",dist
);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: