您的位置:首页 > 其它

hdoj1856 More is better(并查集)

2015-07-29 21:32 281 查看

More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 18729 Accepted Submission(s): 6881



Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,
the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.



Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends.
(A ≠ B, 1 ≤ A, B ≤ 10000000)


Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.



Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8




Sample Output
4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
  【代码】[code]#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 10001000
int i,n,sum;
int per[maxn],ran[maxn];
void init()
{
	sum=0;
	for(i=1;i<=10000000;i++)
	{
		per[i]=i;
	    ran[i]=1;
	}
}
int find(int x)
{
	if(x==per[x])
	  return x;
	return per[x]=find(per[x]);
}
void join(int a,int b)
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
	{
		per[fa]=fb;
		ran[fb]+=ran[fa];
		sum=max(sum,ran[fb]);
	}
}
int main()
{

	while(scanf("%d",&n)!=EOF)
	{
		init();
		if(n==0)
		{
			printf("1\n");
			continue;
		}
		while(n--)
		{ 
		    int a,b;
			scanf("%d%d",&a,&b);
		    join(a,b);
		}
		printf("%d\n",sum);
	}
	return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: