您的位置:首页 > 其它

hdoj1213 How many tables?(并查集)

2015-07-29 21:29 411 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18166 Accepted Submission(s): 8943



Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.



Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.



Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.



Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5




Sample Output
2
4 【代码】[code]#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 1100
int N,M,sum;
int per[maxn];
void init()
{
	for(int i=1;i<=N;i++)
	per[i]=i;
}
int find(int x)
{
	if(x==per[x])
	  return x;
	return per[x]=find(per[x]);
}
void join(int a,int b)
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
	   per[fa]=fb;
		
}
int main()
{
	int T,A,B;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&N,&M);
		init();
		while(M--)
		{
			scanf("%d%d",&A,&B);
			join(A,B);
		}
		sum=0;
		for(int i=1;i<=N;i++)
		  if(i==per[i])
		    sum++;
		printf("%d\n",sum);
	}
	return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: