您的位置:首页 > 其它

hdoj 1856 More is better 【并查集】

2015-07-29 20:42 549 查看

More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 18709 Accepted Submission(s): 6874



[align=left]Problem Description[/align]
Mr Wang wants some boys to help him with a project. Because the project is rather complex,
the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

[align=left]Input[/align]
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends.
(A ≠ B, 1 ≤ A, B ≤ 10000000)

[align=left]Output[/align]
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

[align=left]Sample Input[/align]

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8


[align=left]Sample Output[/align]

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.


[align=left]Author[/align]
lxlcrystal@TJU

[align=left]Source[/align]
HDU 2007 Programming Contest - Final

[align=left]Recommend[/align]
[align=left]分析:[/align]
[align=left]输出集合中最大的数。[/align]
代码:
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#define N 10000000
using namespace std;

int num[N+10];
int  pre[N+10];

void sb(){
for(int i=1;i<=N;i++)
{
pre[i]=i;
num[i]=1;
}
}

int find(int n)

{
int r=n;
//	if(r!=pre[r])
//	return pre[r]=find(pre[r]);
//	return pre[r];
// int r=n;
while(r!=pre[r])
r=pre[r];
int i,j;
i=n;
while(i!=r)
{
j=pre[r];
pre[i]=r;
i=j;
}
return r;
}

void join(int x,int y)
{
int dd,kk;
dd=find(x);
kk=find(y);
if(dd!=kk)
{
pre[dd]=kk;
num[kk]+=num[dd];
}
}

int main()
{
int n,a,b,i,sum,max;
while(~scanf("%d",&n))
{
if(n==0)
{
printf("1\n");
continue;
}
max=0;
sb();
for(i=0;i<n;i++)
{
scanf("%d %d",&a,&b);
if(a>max)
max=a;
if(b>max)
max=b;
join(a,b);
}
int jj=0;
for(i=1;i<=max;i++)
if(jj<num[i])
jj=num[i];
printf("%d\n",jj);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: