您的位置:首页 > 其它

杭电 1213 How Many Tables 并查集

2015-07-29 17:57 323 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18128 Accepted Submission(s): 8929



Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.





Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.





Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.





Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5






Sample Output
2
4



和杭电1232一模一样,只是输入输出有点变化,所以我就改了一下下~~~其他完全一样~~



#include<stdio.h>
int pre[1010];

int find(int x){
	int r,k,j;
	r=x;
	while(pre[r]!=r){
		r=pre[r];
	}
	k=x;
	while(k!=r){
		j=pre[k];
		pre[k]=r;
		k=j;
	}
	return r;
}

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,m;
	    scanf("%d",&n);
		int i,x,y,c,d;
		for(i=1;i<=n;i++) pre[i]=i;
		scanf("%d",&m);
		for(i=1;i<=m;i++){
			scanf("%d%d",&x,&y);
			c=find(x);
            d=find(y);
            if(c!=d)
            {
               pre[d]=c;
           }
	}
		int count=0;
		for(i=1;i<=n;i++){
			if(pre[i]==i) count++;
		}
		printf("%d\n",count);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: