您的位置:首页 > 其它

hdu杭电1213 How Many Tables【并查集】

2015-07-29 17:43 375 查看
Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.



Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.



Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.



Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5




Sample Output
2
4



//找根节点的个数

#include<stdio.h>
int per[100010];
int find(int x)
{
	if(x==per[x]) return x;
	return per[x]=find(per[x]);
}
void join(int x ,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		per[fx]=fy;
	}	
}
int main()
{
	int a,b,m,n,i;
	int t;	
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&m,&n);
		for(i=1;i<=m;++i)
		{
			per[i]=i;
		}		
		while(n--)
		{
			scanf("%d%d",&a,&b);
			join(a,b);
		}	
		int res=0;	
		for(i=1;i<=m;++i)
		{
			if(per[i]==i) ++res;
		}
		printf("%d\n",res);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: