您的位置:首页 > 其它

Radar Installation(POJ--1328

2015-07-29 10:10 477 查看
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar
installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the
distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

题意: x轴相当于一个分界线,有一些岛屿在x轴的上方,要在x轴上放一些雷达,使雷达所能覆盖的地方包括所有的岛屿,如果可以求所需的最少的雷达数,如果不可以直接输出-1.

思路: 以每个岛屿为圆心,以雷达所能覆盖的距离为半径画圆,圆与x轴有两个交点L和R,L与R的区间正是能覆盖此岛屿的雷达能放的区间,将所有岛屿的左右区间以左交点俺从小到大排序,然后再以贪心的思想分三种情况:相邻的两个区间重叠,则两者用一个雷达,此时最右边界为两者交集的最右端;相邻的两个区间有交集而不重叠,两者也是用一个雷达而此时的最右边界不变(两者交集的最右端);相邻的两个区间没有交集,两者用两个雷达,此时最右边界等于右边区间的最右端

注意:对于sqrt()函数,所求结果是什么类型,被开根的数就应该是什么类型,如果不注意这一点的话在一些编译器上可能执行不会出现错误,可是在POJ 上会出现编译错误

Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <cmath>
using namespace std;
struct node
{
int x,y;
double left,right;
} st[1002];
int cmp(node a,node b)
{
return a.left<b.left;
}
int main()
{
int n,d,cnt=0;
double len;
while(~scanf("%d %d",&n,&d))
{
if(n==0&&d==0)
break;
cnt++;
int flag=1;
for(int i=0; i<n; i++)
{
scanf("%d %d",&st[i].x,&st[i].y);
if(st[i].y>d)                                                //标记不可能状况
flag=0;
if(flag)
{
double cc;
cc=(d*d-st[i].y*st[i].y)*1.0;
len=sqrt(cc);
st[i].left=st[i].x-len;                               //计算L和R
st[i].right=st[i].x+len;
}
}
if(flag==0)
{
printf("Case %d: -1\n",cnt);
continue;
}
sort(st,st+n,cmp);                                        //给区间排序
int sum=0;
double r=st[0].right;
for(int i=1; i<n; i++)
{
if(st[i].right<=r)
{
sum++;                                                 //计数重叠区间
r=st[i].right;
}
else if(st[i].left<=r)
sum++;
else
r=st[i].right;
}
printf("Case %d: %d\n",cnt,n-sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: