您的位置:首页 > 其它

hdu 1856 More is better

2015-07-29 10:01 288 查看

More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 18556 Accepted Submission(s): 6827



[align=left]Problem Description[/align]
Mr Wang wants some boys to help him with a project. Because the project is rather complex,
the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

[align=left]Input[/align]
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends.
(A ≠ B, 1 ≤ A, B ≤ 10000000)

[align=left]Output[/align]
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

[align=left]Sample Input[/align]

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8


[align=left]Sample Output[/align]

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.


[align=left]Author[/align]
lxlcrystal@TJU

基础并查集,用一个数组记录树中的节点的个数,

2015,7,29

#include<stdio.h>
#include<string.h>
#define M 10000000+10
int x[M],du[M];//x记录父节点,du记录深度就是节点个数
int num;
int find(int k)
{
if(x[k]==k) return k;
x[k]=find(x[k]);
return x[k];
}
void merge(int a,int b)
{
int fa=find(a);
int fb=find(b);
if(fa==fb) return;
if(du[fa]>=du[fb]) {//把节点少的合并到节点多的树上
x[fb]=fa;
du[fa]+=du[fb];
if(du[fa]>num)
num=du[fa];
}else{
x[fa]=fb;
du[fb]+=du[fa];
if(du[fb]>num)
num=du[fb];
}
}
int main()
{
int n,i,a,b;
while(~scanf("%d",&n)){
for(i=0;i<M;i++){
x[i]=i; du[i]=1;
}
num=-1;
for(i=0;i<n;i++){
scanf("%d%d",&a,&b);
merge(a,b);
}
if(n!=0)//n为0的时候要输出1
printf("%d\n",num);
else printf("1\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: