您的位置:首页 > 其它

poj 3254 Corn Fields 【状压 DP 入门】

2015-07-29 01:50 489 查看
Corn Fields

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 9648Accepted: 5110
Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares
are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice
as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways
he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N

Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0

Sample Output
9

Hint

Number the squares as follows:

1 2 3
  4


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题意:一个矩阵里有很多格子,每个格子有两种状态,可以放牧和不可以放牧,可以放牧用1表示,否则用0表示,在这块牧场放牛,要求两个相邻的方格不能同时放牛,即牛与牛不能相邻。问有多少种放牛方案(一头牛都不放也是一种方案)。

第一道状态压缩DP:理解不是非常好,所以不敢妄写总结。

借鉴大牛博客:http://blog.csdn.net/accry/article/details/6607703

1,dp[ i ][ j ]:状态为j时,到第i行符合条件的可以放牛的方案数。

由此可以得出状态转移方程:dp[ i ][ j ] = (求和)dp[i - 1][ Sj ] (Sj为符合条件的所有状态).

2,对于首行放牛的方案数dp[1][ j ] = 1(状态 j 符合条件) OR 0 (状态 j 不符合条件)

AC代码:

#include <cstdio>
#include <cstring>
#define MOD 100000000 
int dp[15][1<<15];
int N, M; 
int top; 
int state[1<<15];//存储总状态 
int rec[1<<15];//记录每行的状态 
bool one(int x)
{
	if(x & x<<1)//有相邻的1
	return false;
	else
	return true; 
}
bool two(int x, int y)//判断两行是否有相邻的1 
{
	if(x & y) return false;
	return true;
}
void init()
{
	int total = 1<<N;//最多状态数目 
	top = 0;//记录实际数目 
	for(int i = 0; i < total; i++) if(one(i)) state[++top] = i;
}
int main()
{
	while(scanf("%d%d", &M, &N) != EOF)
	{
		init();
		int a;
		for(int i = 1; i <= M; i++)
		{
			rec[i] = 0;//记录状态
			for(int j = 1; j <= N; j++)
			{
				scanf("%d", &a);
				if(a == 0) rec[i] += 1<<(j-1);
			} 
		}
		//初始化第一行状态
		for(int i = 1; i <= top; i++)//枚举所有状态
		{
			if(two(state[i], rec[1]))
			dp[1][i] = 1;
		} 
		//DP更新
		for(int i = 2; i <= M; i++)
		{
			for(int j = 1; j <= top; j++)
			{
				if(!two(state[j], rec[i])) continue;//这一行不能矛盾 
				for(int k = 1; k <= top; k++)
				{
					if(!two(state[k], rec[i-1])) continue;//上一行不能矛盾 
					if(!two(state[k], state[j])) continue;//两个状态不能矛盾 
					dp[i][j] = (dp[i][j] + dp[i-1][k]) % MOD;//累加 更新 
				}
			} 
		}
		int ans = 0;
		for(int i = 1; i <= top; i++)//累加所有状态  
		ans = (ans + dp[M][i] ) % MOD; 
		printf("%d\n", ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: