您的位置:首页 > Web前端

Fence Repair(POJ--3253

2015-07-28 21:47 507 查看
Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs
N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length
Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the
N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the
N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the
N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer
N, the number of planks

Lines 2..N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make
N-1 cuts

题意:有一个木板,要切成n块,要切n-1刀,给你n个数代表这n个板子的长度,切这块板子需花的钱数就等于这块板子被切之前的长度,求得到n块板子需花的最少钱数

思路:用优先队列,要切就切花费最少的,把每个板子的长度放到优先队列里,则花费最少的切法即优先队列里最头上的两个板子长度的加和.(该题如果用整型则WA,若改为long long 就过了,目前本渣也不造咋回事2333

Sample Input
3
8
5
8

Sample Output
34

Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into
16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
<span style="font-size:18px;">#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#define ll long long
using namespace std;
int main()
{
ll n,a,b,c;
while(~scanf("%lld",&n))
{
ll sum=0;
priority_queue<ll,vector<ll>,greater<ll> >ss;
for(ll i=0; i<n; i++)
{
ll x;
scanf("%lld",&x);
sum+=x;                                       //先把总长度求出来
ss.push(x);
}
while(ss.size()>2)                              //当队列的长度还有2个时则证明已遍历完
{
a=ss.top();
ss.pop();
b=ss.top();
ss.pop();
c=a+b;
sum+=c;
ss.push(c);
}
printf("%lld\n",sum);
}
return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: