您的位置:首页 > 其它

网格中矩形的个数

2015-07-28 21:29 204 查看
网格中矩形的个数

题目链接:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=84562#problem/N

题目:

Description

给你一个高为n ,宽为m列的网格,计算出这个网格中有多少个矩形,下图为高为2,宽为4的网格.



Input

第一行输入一个t, 表示有t组数据,然后每行输入n,m,分别表示网格的高和宽 ( n < 100 , m < 100).

Output

每行输出网格中有多少个矩形.

Sample Input

2
1 2
2 4

Sample Output

3
30

分析:找出规律即可
每个n*m的网格中矩形的个数为1加到n乘以1加到m。

#include<iostream>
using namespace std;
int main()
{
int t,n,m,x,y;
cin>>t;
while(t--)
{
cin>>n>>m;
x=(1+n)*n/2;
y=(1+m)*m/2;
cout<<x*y<<endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: